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6. Application Example

In TOL2 we use exactly the same application example as in TOL1. This means it is easy to determine the
differences and advantages of TOL2.

An application example will show you how the tolerance calculation works. A safety switch is to be designed
which will be used to turn off a machine.
A micro-switch is used as the switching element. The following drawing shows the switching element:

For safe use the switching zone for the actuator is as follows:
Position off: > 3.3 mm i.e. the switch may not be loaded
Position on: > 1.5 mm: switching not yet guaranteed
                    < 0.5 mm: damage possible.

The tolerance calculation will check whether the switch points are adhered to. In addition, the total
dimensions with tolerances will be ascertained with tolerances.

The TOL1 manual explains how two files, S_ON for the end switch in position "on", and S_OFF for the end
switch in position "off" are created. The disadvantage of this method, is that most dimensions and
dependencies must be entered for both files.

Using the new method together with TOL2, five TOL1 files (instead of only one) are created, one each for
case, ram, switch, cover and locking ring. These five individual parts are combined in two different ways in
TOL2: one combination is the switch position "on", the other is with the switch position "off".
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6.1. Design Draft

First of all a design draft is created. The micro switch is installed in a case and covered with a cover. The
micro switch is operated with a ram against the force of a compression spring.

6.2. Part Drawings

A drawing is created for each of the following: case, ram and cover.
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6.3. Assembly Unit and Part List

The assembly unit drawing and part list show the drawings for the following parts: case, ram and cover, the
switch as well as the standard parts locking ring and compression spring.

6.4. Element Draft and Element Table

As opposed to the description in the TOL1 manual, a draft drawing and table is not created of the whole end
switch, but rather of all element parts. The element tables are then created in relation to the element drafts,
with links to the element numbers via dimension, tolerance and dimension direction. The individual parts,
case, ram, switch, locking ring and cover are entered in TOL1 and then linked to TOL2.
We will start with the case. The dimension planes which are to be used are numbered consecutively from
zero to four.
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The elements are linked via the previous element, direction and dimensions. This element table is entered in
TOL1, as described in the TOL1 manual.

Under "View->Whole Graphic" you can check the correctness of the entries.

Under "View->Excerpt" the element tables are printed out with the dimensions.
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Element table for case

       ======================================================================
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ======================================================================
         1     0   -    15.000    0.100   -0.100   .....   upper end
         2     4   +    29.000    0.100   -0.100   .....   drill hole
         3     4   +    21.000    0.100   -0.100   .....   switch mount
         4     0   -    53.000    0.200   -0.200   .....   lower end

Element table for tappet

       ======================================================================
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ======================================================================
         1     3   +    31.000    0.100   -0.100   .....   case link
         2     3   +    23.000    0.200   -0.200   .....   other
         3     0   -    39.000    0.200   -0.200   .....   lower end
         4     3   +     3.000    0.100   -0.100   .....   ring lower
         5     4   +     1.100    0.100    0.000   .....   ring upper

Element table for cap (switch cover)
Only one single dimension of this part is relevant for the tolerance calculation.

       ======================================================================
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ======================================================================
         1     0   -     5.000    0.000   -0.200   .....   lower end

Element table for the switch

       ======================================================================
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ======================================================================
         1     0   -    16.000    0.000   -0.200   .....   lower end
         2     0   +     3.000    0.300   -0.300   .....   switch head
         3     0   +     1.500    0.500    0.000   .....   SM1
         4     0   +     0.500    0.000    0.000   .....   SM2

Element table for the locking ring.
The only relevent dimension for the locking ring is thickness.

       ======================================================================
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ======================================================================
         1     0   -     1.000    0.000   -0.060   h11     lower end
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6.5. Linking the Individual Parts with TOL2

In TOl2 you now need to define how the individual parts are linked to one another. The link is different for the
switch positions "on" and "off".

Switch position "on"
The ram is pushed until it reaches the upper edge of the case. The group link occurs between element zero
of the case and element one of the ram. A second "twig" goes from element three of the case to element one
of the switch, then further to element one of the switch and then element zero of the case.

Switch Position "off"
The ram is pushed upwards by a compression spring until the locking ring meets the case. The link occurs
for this reason from element two of the case to element zero of the locking ring, then from element one of the
locking ring to element four of the ram. The link for the switch and cover is the same as for the switch
position "on".

Input Groups in TOL2 for Switch Position "on"
Anologue to the root element zero in TOL1, a root group zero must be defined in TOL2. In the example the
case is the root group. Under "Edit->Group 0" the file name "1_GEH" is entered or selected. Afterwards the
other individual elements and their links can be entered under "Edit->Groups".

For the entry of new assembly units the following applies: The previous group must be known. The first new
assembly group must also have the group zero as predecessor. In the example you can commence with
entry of the ram or switch.

Under "Group1 - Group" select the file name "tappet" for the ram, then element 1 (case link) as the linking
element. Predecessor group is "case", linking element 0. As the ram is directly located on the case, the
distance is 0, as seam and shape tolerance you can enter +/- 0.05. The direction is not important when the
distance is zero. Then enter the locking ring, it's element 1 is located directly on element 4 of the ram. This is
followed by the switch with element zero on element 3 of the case, and finally, the case with element zero on
element one of the switch.
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Under "View->Groups" and "Excerpt" you get a list of the dimension groups with all dimension elements.

       Group 0: Case 001 (Case)
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       0.0   0.0   +     0.000    0.000    0.000   .....   0 Case
       0.1   0.0   -    15.000    0.100   -0.100   .....   upper end
       0.2   0.4   +    29.000    0.100   -0.100   .....   drill hole
       0.3   0.4   +    21.000    0.100   -0.100   .....   switch mount
       0.4   0.0   -    53.000    0.200   -0.200   .....   lower end
       ----------------------------------------------------------------------

       Group 1: tappet 002 (tappet)
       Link: Element 1 with Element 0 in Group 0 (Case)
       dimension: + 0  ± 0.05
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       1.0   1.3   +    39.000    0.200   -0.200   .....   0 tappet
       1.1   0.0   +     0.000    0.050   -0.050   .....   case link
       1.2   1.3   +    23.000    0.200   -0.200   .....   other
       1.3   1.1   -    31.000    0.100   -0.100   .....   lower end
       1.4   1.3   +     3.000    0.100   -0.100   .....   ring lower
       1.5   1.4   +     1.100    0.100    0.000   .....   ring upper
       ----------------------------------------------------------------------

       Group 2: Ring 005 (ring)
       Link: Element 1 with Element 4 in Group 1 (tappet)
       dimension: + 0  ± 0.05
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       2.0   2.1   +     1.000    0.000   -0.060   h11     0 Ring
       2.1   1.4   +     0.000    0.050   -0.050   .....   lower end
       ----------------------------------------------------------------------

       Group 3: Micro Switch 004 (switch)
       Link: Element 0 with Element 3 in Group 0 (Case)
       dimension: + 0  ± 0.05
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       3.0   0.3   +     0.000    0.050   -0.050   .....   0 Micro Switch
       3.1   3.0   -    16.000    0.000   -0.200   .....   lower end
       3.2   3.0   +     3.000    0.300   -0.300   .....   switch head
       3.3   3.0   +     1.500    0.500    0.000   .....   SM1
       3.4   3.0   +     0.500    0.000    0.000   .....   SM2
       ----------------------------------------------------------------------

       Group 4: Abschlußdeckel 003 (cover)
       Link: Element 0 with Element 1 in Group 3 (Micro Switch)
       dimension: + 0  ± 0.05
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       4.0   3.1   +     0.000    0.050   -0.050   .....   0 Abschlußdecke
       4.1   4.0   -     5.000    0.000   -0.200   .....   lower end
       ----------------------------------------------------------------------
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Input of Critical Distances in TOL2 for Switch Position "on"

Now the critical distances can be entered. These are:
1. Switch-ram: Element zero of switch group to element three in ram group.
2. Stroke: Element zero in Siri group to element two in case group.
3. End cover: Element zero in cover group to element four of case.
4. Total length: Element zero in ram group to element four of case.

The tolerance chain is automatically calculated when you finish the entries. Under "View->Excerpt" you can
display the elements and calculated closing dimension. Under "View->Standard" an additional statistical
evaluation is carried out.

       ----------------------------------------------------------------------
       TOL2 - Tolerance Calculation      Version 3.0
       License No. 0109  * * *  KUNT ELEKTRONIK
       C:\VOL3\APPS\TP\TRAIN\S_ON.tl2   15.11.2013 8:48
       ----------------------------------------------------------------------
       Application Example
       Switch
       in Position "on"
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       0.1   0.0   -    15.000    0.100   -0.100   .....   upper end
       0.2   0.4   +    29.000    0.100   -0.100   .....   drill hole
       0.3   0.4   +    21.000    0.100   -0.100   .....   switch mount
       0.4   0.0   -    53.000    0.200   -0.200   .....   lower end
       1.0   1.3   +    39.000    0.200   -0.200   .....   0 tappet
       1.1   0.0   +     0.000    0.050   -0.050   .....   case link
       1.2   1.3   +    23.000    0.200   -0.200   .....   other
       1.3   1.1   -    31.000    0.100   -0.100   .....   lower end
       1.4   1.3   +     3.000    0.100   -0.100   .....   ring lower
       1.5   1.4   +     1.100    0.100    0.000   .....   ring upper
       2.0   2.1   +     1.000    0.000   -0.060   h11     0 Ring
       2.1   1.4   +     0.000    0.050   -0.050   .....   lower end
       3.0   0.3   +     0.000    0.050   -0.050   .....   0 Micro Switch
       3.1   3.0   -    16.000    0.000   -0.200   .....   lower end
       3.2   3.0   +     3.000    0.300   -0.300   .....   switch head
       3.3   3.0   +     1.500    0.500    0.000   .....   SM1
       3.4   3.0   +     0.500    0.000    0.000   .....   SM2
       4.0   3.1   +     0.000    0.050   -0.050   .....   0 Abschlußdeckel
       4.1   4.0   -     5.000    0.000   -0.200   .....   lower end
       999
       ----------------------------------------------------------------------

       Closing dimensions for constant distribution
       ----------------------------------------------------------------------
       Distanc  Nom.dim.   Up.t.  L.tol.Max.clear.Min.clear. Comment
       ----------------------------------------------------------------------
       3.0 1.3     1.000   0.500  -0.500     1.500     0.500 switch-mandrel
       ----------------------------------------------------------------------
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       2.0 0.2     3.000   0.660  -0.600     3.660     2.400 stroke
       ----------------------------------------------------------------------
       4.1 0.4     0.000   0.200  -0.600     0.200    -0.600 cap
       ----------------------------------------------------------------------
       1.0 0.4   -61.000   0.550  -0.550   -60.450   -61.550 total length
       ----------------------------------------------------------------------

       Closing dimensions for Gaussian distribution
       ----------------------------------------------------------------------
       Distanc  Mid.dim.   Up.t.  L.tol.Max.clear.Min.clear. Comment
       ----------------------------------------------------------------------
       3.0 1.3     1.000   0.255  -0.255     1.255     0.745 switch-mandrel
       ----------------------------------------------------------------------
       2.0 0.2     3.030   0.275  -0.275     3.305     2.755 stroke
       ----------------------------------------------------------------------
       4.1 0.4    -0.200   0.187  -0.187    -0.013    -0.387 cap
       ----------------------------------------------------------------------
       1.0 0.4   -61.000   0.304  -0.304   -60.696   -61.304 total length
       ----------------------------------------------------------------------

If you don't arrive at these values, you can transfer the dimensions to CAD or have a scale drawing printed
out. This is done with DXFPLOT (if you have it) under "CAD->Whole Graphic". In the graphic you can see
which dimension or link does not agree with the preset values.
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In the view menu you can see the dimension chain for the entered closing dimension. There are displays as
a table, a scale graphic and as a schematic graphic.

       ----------------------------------------------------------------------
       DIMENSIONAL STRUCTURE : 3.0 => 0.3 => 0.4 => 0.0 <= 1.1 <= 1.3
       ----------------------------------------------------------------------
       ----------------------------------------------------------------------
       1. Classic Method at constant distribution:

       3.0 ===> 1.3      Max.dim.    :    1.500                     0.500
                         Nom.dim.    :    1.000             1.000 --------
       switch-mandrel    Min.dim.    :    0.500                    -0.500
       ----------------------------------------------------------------------

       ----------------------------------------------------------------------
       2. Statistical method at Gaussian distribution

       3.0 ===> 1.3      Max.dim.    :    1.255                     0.255
                         Aver.dim.   :    1.000             1.000 --------
       switch-mandrel    Min.dim.    :    0.745                    -0.255
       ----------------------------------------------------------------------

       ----------------------------------------------------------------------
       closing dim.:    1.000 +/-  0.255 at  +/-  3.00 Sigma
       ----------------------------------------------------------------------
       1. probability range
       ----------------------------------------------------------------------
          z      expectation                     expectation       proba-
       [Sigma]     value        probability        value           bility
       ----------------------------------------------------------------------
        -5.0    X <     0.575     0.00003 %      X >     0.575   99.99997 %
        -4.0    X <     0.660     0.00317 %      X >     0.660   99.99683 %
        -3.0    X <     0.745     0.14000 %      X >     0.745   99.86000 %
        -2.0    X <     0.830     2.28000 %      X >     0.830   97.72000 %
        -1.0    X <     0.915    15.90000 %      X >     0.915   84.10000 %
         0.0    X <     1.000    50.00000 %      X >     1.000   50.00000 %
         1.0    X <     1.085    84.10000 %      X >     1.085   15.90000 %
         2.0    X <     1.170    97.72000 %      X >     1.170    2.28000 %
         3.0    X <     1.255    99.86000 %      X >     1.255    0.14000 %
         4.0    X <     1.340    99.99683 %      X >     1.340    0.00317 %
         5.0    X <     1.425    99.99997 %      X >     1.425    0.00003 %
       ----------------------------------------------------------------------

       2. probability interval
       ----------------------------------------------------------------------
         z         dimension interval            proba-          reject
       [Sigma]     for expectation value         bility          rate
       ----------------------------------------------------------------------
         0.5        0.958 < X <     1.042       38.30000 %    61.70000 %
         1.0        0.915 < X <     1.085       68.26000 %    31.74000 %
         1.5        0.873 < X <     1.127       86.64000 %    13.36000 %
         2.0        0.830 < X <     1.170       95.44000 %     4.56000 %
         2.5        0.788 < X <     1.212       98.76000 %     1.24000 %
         3.0        0.745 < X <     1.255       99.73000 %     0.27000 %
         3.5        0.703 < X <     1.297       99.95000 %     0.05000 %
         4.0        0.660 < X <     1.340       99.99370 %     0.00630 %
         4.5        0.618 < X <     1.382       99.99932 %     0.00068 %
         5.0        0.575 < X <     1.425       99.99994 %     0.00006 %
       ----------------------------------------------------------------------
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Dimension chain as table for distance switch-ram

       DIMENSION CHAIN    T = 20°C
       ----------------------------------------------------------------------
       El.No.  Text                    Distance              Pos.     perct.
       ----------------------------------------------------------------------
       3.0    0 Micro Switch                                 0.000
                                    -     0.000 ± 0.05                  10 %
       0.3    switch mount                                   0.000
                                    -    21.000 ± 0.1                   20 %
       0.4    lower end                                    -21.000
                                    +    53.000 ± 0.2                   40 %
       0.0    0 Case                                        32.000
                                    +     0.000 ± 0.05                  10 %
       1.1    case link                                     32.000
                                    -    31.000 ± 0.1                   20 %
       1.3    lower end                                      1.000
       ----------------------------------------------------------------------
       3.0 -> 1.3: switch-mandrel       1.000   ± 0.5  ( ± 0.25 stat.)
       ----------------------------------------------------------------------

Schematic drawing of dimension chain for stroke    Dimension chain for total length as scale graphic

Under "View->Cross Reference" TOL2 analyses which elements of the dimension chain are involved with the
closing dimensions.

Please don't forget to save the file before calculating the switch position "off".
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Group entry in TOL2 for switch position "off"

At the switch position "off" the ram is linked to the case via the locking ring. The root group is also the case,
the link for the switch and end cover is also the same.

Critical distances in switch position "off" are:
1. ram-switch button: element two of ram group to element two of switch group.
2. Overhang cover case: Element three of case group to element one of cover group.
3. Total length: Element four of case group to element zero of ram group.
4. Switch trvael: Element zero of case group to element one of ram group.

Under "View->Groups" the input data and the links for the dimension elements are listed via global element
numbers.

       Group 0: Case 001 (Case)
       Material:                                           alphaT: 0
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       0.0   0.0   +     0.000    0.000    0.000   .....   0 Case
       0.1   0.0   -    15.000    0.100   -0.100   .....   upper end
       0.2   0.4   +    29.000    0.100   -0.100   .....   drill hole
       0.3   0.4   +    21.000    0.100   -0.100   .....   switch mount
       0.4   0.0   -    53.000    0.200   -0.200   .....   lower end
       ----------------------------------------------------------------------

       Group 1: Ring 005 (ring)
       Material:                                           alphaT: 0.0000115
       Link: Element 0 with Element 2 in Group 0 (Case)
       dimension: + 0  ± 0.05
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       1.0   0.2   +     0.000    0.050   -0.050   .....   0 Ring
       1.1   1.0   -     1.000    0.000   -0.060   h11     lower end
       ----------------------------------------------------------------------

       Group 2: tappet 002 (tappet)
       Material:                                           alphaT: 0
       Link: Element 4 with Element 1 in Group 1 (Ring)
       dimension: + 0  ± 0.05
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       2.0   2.3   +    39.000    0.200   -0.200   .....   0 tappet
       2.1   2.3   +    31.000    0.100   -0.100   .....   case link
       2.2   2.3   +    23.000    0.200   -0.200   .....   other
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       2.3   2.4   -     3.000    0.100   -0.100   .....   lower end
       2.4   1.1   +     0.000    0.050   -0.050   .....   ring lower
       2.5   2.4   +     1.100    0.100    0.000   .....   ring upper
       ----------------------------------------------------------------------

       Group 3: Micro Switch 004 (switch)
       Material:                                           alphaT: 0
       Link: Element 0 with Element 3 in Group 0 (Case)
       dimension: + 0  ± 0.05
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       3.0   0.3   +     0.000    0.050   -0.050   .....   0 Micro Switch
       3.1   3.0   -    16.000    0.000   -0.200   .....   lower end
       3.2   3.0   +     3.000    0.300   -0.300   .....   switch head
       3.3   3.0   +     1.500    0.500    0.000   .....   SM1
       3.4   3.0   +     0.500    0.000    0.000   .....   SM2
       ----------------------------------------------------------------------

       Group 4: Abschlußdeckel 003 (cover)
       Material:                                           alphaT: 0
       Link: Element 0 with Element 1 in Group 3 (Micro Switch)
       dimension: + 0  ± 0.05
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       4.0   3.1   +     0.000    0.050   -0.050   .....   0 Abschlußdecke
       4.1   4.0   -     5.000    0.000   -0.200   .....   lower end
       ----------------------------------------------------------------------

       critical distances (closing dim.)
       ----------------------------------------------------------------------
        Nr.  El.  ->  El.  Text
       ----------------------------------------------------------------------
         1:  3.2  ->  2.3  clearance
       ----------------------------------------------------------------------
         2:  0.4  ->  4.1  cover-case
       ----------------------------------------------------------------------
         3:  0.4  ->  2.0  total length
       ----------------------------------------------------------------------
         4:  0.0  ->  2.1  stroke
       ----------------------------------------------------------------------
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Excerpt with calculation of critical distances:

       ----------------------------------------------------------------------
       TOL2 - Tolerance Calculation      Version 3.0
       ----------------------------------------------------------------------
       Application example
       Industrial Switch
       in "off" position
       ----------------------------------------------------------------------
       El. Pred.   ±  Nom.dim.  Up.Dev. Low.Dev.    ISO    Text
       ----------------------------------------------------------------------
       0.1   0.0   -    15.000    0.100   -0.100   .....   upper end
       0.2   0.4   +    29.000    0.100   -0.100   .....   drill hole
       0.3   0.4   +    21.000    0.100   -0.100   .....   switch mount
       0.4   0.0   -    53.000    0.200   -0.200   .....   lower end
       1.0   0.2   +     0.000    0.050   -0.050   .....   0 Ring
       1.1   1.0   -     1.000    0.000   -0.060   h11     lower end
       2.0   2.3   +    39.000    0.200   -0.200   .....   0 tappet
       2.1   2.3   +    31.000    0.100   -0.100   .....   case link
       2.2   2.3   +    23.000    0.200   -0.200   .....   other
       2.3   2.4   -     3.000    0.100   -0.100   .....   lower end
       2.4   1.1   +     0.000    0.050   -0.050   .....   ring lower
       2.5   2.4   +     1.100    0.100    0.000   .....   ring upper
       3.0   0.3   +     0.000    0.050   -0.050   .....   0 Micro Switch
       3.1   3.0   -    16.000    0.000   -0.200   .....   lower end
       3.2   3.0   +     3.000    0.300   -0.300   .....   switch head
       3.3   3.0   +     1.500    0.500    0.000   .....   SM1
       3.4   3.0   +     0.500    0.000    0.000   .....   SM2
       4.0   3.1   +     0.000    0.050   -0.050   .....   0 Abschlußdeckel
       4.1   4.0   -     5.000    0.000   -0.200   .....   lower end
       999
       ----------------------------------------------------------------------

       Closing dimensions for constant distribution
       ----------------------------------------------------------------------
       Distanc  Nom.dim.   Up.t.  L.tol.Max.clear.Min.clear. Comment
       ----------------------------------------------------------------------
       3.2 2.3     1.000   0.810  -0.750     1.810     0.250 clearance
       ----------------------------------------------------------------------
       0.4 4.1     0.000   0.600  -0.200     0.600    -0.200 cover-case
       ----------------------------------------------------------------------
       0.4 2.0    64.000   0.560  -0.500    64.560    63.500 total length
       ----------------------------------------------------------------------
       0.0 2.1     3.000   0.660  -0.600     3.660     2.400 stroke
       ----------------------------------------------------------------------

       Closing dimensions for Gaussian distribution
       ----------------------------------------------------------------------
       Distanc  Mid.dim.   Up.t.  L.tol.Max.clear.Min.clear. Comment
       ----------------------------------------------------------------------
       3.2 2.3     1.030   0.358  -0.358     1.388     0.672 clearance
       ----------------------------------------------------------------------
       0.4 4.1     0.200   0.187  -0.187     0.387     0.013 cover-case
       ----------------------------------------------------------------------
       0.4 2.0    64.030   0.257  -0.257    64.287    63.773 total length
       ----------------------------------------------------------------------
       0.0 2.1     3.030   0.275  -0.275     3.305     2.755 stroke
       ----------------------------------------------------------------------


